The WooCommerce plugin is not PCI-DSS certified. However, this does not prevent your site from becoming PCI compliant. 
 

For more information on this plugin and PCI compliance please refer to the WooCommerce documentation on PCI compliance.