Recent versions of The Raiser's Edge support TLS 1.2 encryption, which is the recommended encryption protocol.

Use of TLS 1.2 encryption is enabled and supported by a combination of .NET Framework version 4.5 or above being installed on each workstation and server, and Raiser’s Edge 7.95, patch 3 or above being installed. 

If you are hosted by Blackbaud:
All servers in Blackbaud Hosting Services are confirmed to be using current versions of .NET Framework, so are guaranteed to be processing payments via TLS 1.2 encryption. 

If you are not hosted by Blackbaud:
System administrators should work directly with their security team to confirm the correct way to address the requirements of PCI 3.1. In order to enable and utilize TLS 1.2, you will need to be on at least version 7.95, patch 3 and your workstations and application server will need Microsoft .NET Framework 4.5.2 or higher installed.  NOTE: Raiser's Edge 7.95 patch 2 and below do not support processing payments through TLS 1.2, even if .NET Framework 4.6 is installed. 

Raiser's Edge 7.96 patch 1 requires .NET Framework 4.6, so it is guaranteed to process payments using TLS 1.2.

For more information, see How to prepare for the installation of Microsoft .NET Framework 4.6 which is required for Raiser's Edge 7.96, and review the following article before upgrading from 7.93 > 7.95 or above: What do I need to do to prepare for the update to The Raiser's Edge 7.95 or higher?

More information can also be found in the 7.96 release webinar on the Raiser's Edge New Release Community.