How is Raiser's Edge Affected by PCI 3.1 and TLS 1.1 requirements?

Payment processing and credit card tokenization in The Raiser's Edge uses SSL or TLS security protocols.

​In April 2015, Payment Card Industry Data Security Standard (PCI DSS) 3.1 was released and addresses security concerns with all SSL and early TLS cryptography. PCI 3.1 defines these levels of cryptography as vulnerable and mandates a transition to TLS 1.1 or higher by June 2018.

How does this mandate impact The Raiser's Edge?
Blackbaud is requiring customers to upgrade to versions of their products that support TLS v.1.1 or higher by March 15, 2018. On that date, Blackbaud will begin disabling the TLS v.1.0 encryption protocol in our solutions, so Blackbaud can complete development and testing prior to the PCI Council’s June 30, 2018 deadline. After March 15, 2018, customers still using TLS v.1.0 will not be able to access some of their Blackbaud solutions.

For locally-installed Raiser’s Edge:
Users will need to upgrade to 7.96 and the latest patch. See Upgrade for PCI Compliance for more information

Note: If your organization also plans to disable TLS 1.0 in your local environment, see How do I prepare to disable TLS 1.0 when using The Raiser's Edge on premise?

See Upgrade for PCI Compliance for full information, including information on operating systems and browsers.

For more information on preparing to the upgrade to 7.96, see How to prepare for the installation of Microsoft .NET Framework 4.6 which is required for Raiser's Edge 7.96, and review the following article before upgrading from 7.93: What do I need to do to prepare for the update to The Raiser's Edge 7.95 or higher?

More information can also be found in the 7.96 release webinar on the Raiser's Edge New Release Community.

Steps to Duplicate

Was this article helpful?