This error indicates there is a version mismatch between the NetCommunity components Blackbaud hosts and the components your organization hosts. To resolve, the components will need to be upgraded. 

How to install or update Blackbaud NetCommunity 7.x when Blackbaud NetCommunity is hosted and The Raisers Edge is not hosted by Blackbaud Hosting Services