Currently The Financial Edge 7.87 is compatible with Microsoft Office 2013 32 bit installations but 64 bit installations are not compatible nor supported. 

 

 

The Financial Edge system requirements