How do I apply a FIMS patch?

Patch files are small and designed to resolve a few issues. They must be installed using the FIMS Update and Patch Utility.  These steps are different from those used to upgrade FIMS.
  1. Download the patch file from the MicroEdge Resource Library.
  1. Copy the FIMS Patch file to FIMS subfolder on the server or workstation on which the patch is being installed:
  • Server Location: X:\npo\found\FIMS (X refers to the letter of the drive that you actually have FIMS installed.)
  • Workstation location: N:\found\FIMS
  1. Log in to FIMS.
  2. Open Tools > System Utilities > FIMS Update and Patch Utility.
  3. Click Browse and select the patch file.
  4. Click Open to display the patch notes.
  5. Begin the process by clicking Install.
NOTE: If you see a ‘single-user mode’ error, please see below.
  1. When complete, a FIMS EMail prompt with Update Complete will pop-up, click Cancel.
  2. Log in to FIMS and Select Help > About FIMS.
  3. Click on the button "Patch Level".
  4. The patch you just applied should be listed at the top.  Click ok and ok.
Your patch is now complete.


Single-User Mode Error Troubleshooting
If you are a single user, you may get an error during the installation that says something like “database found is in use in single-user mode” (your exact message may be different but single-user mode will be part of it).
To resolve this issue, follow the steps below:
  1. Press OK and let the installation process complete.
  2. Once it is completed, you will need to run the FIMS compiler before you use any of the patched programs. To do this, follow these steps.
    1. From the main FIMS screen, select Tools > System Utilities > Admin Utilities > FIMS Compiler.
    2. Press the Compile button.
    3. You will see a scrolling area of programs being compiled. When it completes, you will get a dialog box that says something like this (number of programs may vary):
User-added image
  1. Press OK.
Your patch is now complete.

Environment

 FIMS

Was this article helpful?