What does the deprecation of TLS 1.0 mean for Blackbaud clients?

After TLS 1.0 is deprecated it may be necessary to update local software to continue to be able to connect to Blackbaud-hosted email and payment services.

For hosted or cloud solutions by Blackbaud, your products and services will be upgraded as a part of normal maintenance windows to ensure applications are compliant with TLS 1.1 or higher.

If applications, services, or customizations are installed locally, you will be responsible for updating to a compliant version (or confirming you are already on a compliant version).

More information, including compliant versions for specific products can be found on Blackbaud's TLS Landing Page and FAQ: https://www.blackbaud.com/tls


 


 

Environment

 Chrome;Firefox;Internet Explorer;Opera;Safari
 Windows 7 (32-bit);Windows 7 (64-bit);Windows 8 (32-bit);Windows 8 (64-bit);Windows 8.1 (32-bit);Windows 8.1 (64-bit);Windows 10 (32-bit);Windows 10 (64-bit);Windows Server 2003 (32-bit);Windows Server 2003 (64-bit);Windows Server 2003 R2 (32-bit);Windows Server 2003 R2 (64-bit);Windows Server 2008 (32-bit);Windows Server 2008 (64-bit);Windows Server 2008 R2;Windows Server 2012;Windows Server 2012 R2;Windows Server 2016

Was this article helpful?