Blackbaud customer's should review and implement the actionable items from for their primary solutions.

Raiser's Edge
Payment processing and credit card tokenization in The Raiser's Edge uses SSL or TLS security protocols. Blackbaud is requiring customers to upgrade to versions of their products that support TLS v.1.1 or higher by March 15, 2018. On that date, Blackbaud will begin disabling the TLS v.1.0 encryption protocol in our solutions, so Blackbaud can complete development and testing prior to the PCI Council’s June 30, 2018 deadline. After March 15, 2018, customers still using TLS v.1.0 will not be able to access some of their Blackbaud solutions.

For locally-installed Raiser’s Edge:
Users will need to upgrade to an upcoming 7.96 patch currently planned for release by the end of the year. If TLS 1.0 is disabled in your local environment and the compatible version of Raiser’s Edge is not installed, users will receive an error (Error: Unable to establish database connection) and be unable to log in.
Reference What do I need to do to prepare for the update to The Raiser's Edge 7.95 or higher? for recommended preparation and How to prepare for the installation of Microsoft .NET Framework 4.6 which is required for Raiser's Edge 7.96. Reference Upgrade for PCI Compliance for full information, including information on operating systems and browsers.

Luminate Online
For customers on our cloud solutions (such as Raiser’s Edge NXT, Financial Edge NXT, Luminate CRM, eTapestry, and Altru), you are always current with the latest security requirements. We have or will soon automatically release TLS v1.1+ compatible versions of your solution and you don’t need to take steps to upgrade your software.

You still need to ensure that your OS and browsers have been upgraded to support TLS v1.1+, and to notify your constituents:
  • Notify your constituents to upgrade their OS and browser to TLS v.1.1+ supported versions, to ensure continuity of communications and transactions. For example, donors, patrons, parents and students accessing donor pages, store fronts, community pages and online registration pages hosted within on-premise environments are susceptible to vulnerability and connectivity issues if they do not upgrade their OS and browser to support TLS v.1.1+.