This can be caused by a version mismatch if you are split hosted. For example, If Blackbaud NetCommunity has been upgraded to Service Pack 3 while The Raiser's Edge Web Services server (REWS) is on Service Pack 2, this error can be generated as a result. The error only shows when creating new parts by navigating to Site explorer > Parts or when editing a page and creating a new part on the page. Existing parts will continue to function, and you can edit existing parts. 

To resolve this error, update The Raiser's Edge Web Services server.