ERROR: The request was aborted: Could not create SSL/TLS secure channel

Client is trying to log into Sphere through the Raiser's Edge Sphere connector and received this error
There are many possible reasons for this issue.

Possible cause of this error.

*Your server doesn't have a valid HTTPS certificate
*You are using an outdate version of RE or Connector
*You are using TLS 1.0

>As of February of this year (2018), Raiser’s Edge Sphere Connector supports .NET 4.5 to comply with the Transport LayerSecurty (TLS) 1.1 and 1.2 protocols for enhanced communication security over the Internet.
The Microsoft .NET Framework 4.5.1 is a highly compatible, in-place update to the Microsoft .NET Framework 4 and the Microsoft .NET Framework 4.5 so make sure you upgrade.

>As of March 15, 2018 - if you still using TLS v.1.0, you will not be able to use the Connector. You are require to upgrade to TLS 1.1 or higher
Ensure that you have upgraded to TLS v.1.1+ accepted Blackbaud products. See link below for versions of Blackbaud products that support TLS v.1.1+
Ensure that your OS and browsers have been upgraded to support TLS 1.1+. See link below for operating systems and browsers that support TLS 1.1+
Here is the link

>You must use Raiser's Edge 7.96 or higher.
Click here to check for the current version of Raiser's Edge?
>You must have Raiser's Edge Sphere Connector 4.1.4.9 
Click here to check for the current version of RE Sphere Connector?
Click here to upgrade your Connector.
 

Environment

 Blackbaud Sphere

Was this article helpful?