Your organization's mail server is attempting to connect using the deprecated TLS 1.0 protocol. Blackbaud no longer allows connections over this protocol. In order to resolve it, your organization needs to ensure their mail servers are connecting using TLS 1.1 or higher.