How do I setup an ODBC Connection on my FIMS workstation?

For anyone using an ODBC DSN for Crystal Reports or another application that wants to connect to the FIMS database, create an ODBC Data Source (DSN) on each workstation by following these instructions.

If you get a new workstation, you will need to re-make the ODBC data source.
To run this procedure, you will need to be logged into the workstation with administrative rights. 
  1. Log into FIMS
  2. There are two ways to bring up the ODBC Configuration:
    1. From the FIMS menu: Tools > System Utilities > Admin Utilities > SQL Tools > ODBC 92 Configuration
User-added image
OR​
  1. Running the procedure: Tools > System Utilities > Run Procedure
User-added image
  1. Enter the procedure name gui\system\d-odbc92.w.  Leave the 2 boxes unchecked and click OK.
User-added image
  1. The ODBC configuration screen opens.
User-added image
The information should default in correctly and none of the 3 boxes at the bottom should be checked. 
  1. Host Name = name of the server (this is where the FIMS software is installed)
  2. User Id = your FIMS User ID.  Click OK.
If you get the following message because you already have an ODBC DSN setup, Select > Yes
 User-added image
When the FIMS – ODBC 92 Configuration window opens, Select> Yes
User-added image 
When the FIMS – ODBC 92 Configuration window opens, Select > OK
User-added image
If you receive a series of error messages 'Unable to open file: odbcin92.log. Errno=13, (98)', then you do not have rights to edit the Windows registry.  You'll need to log out of the workstation as your Windows user and log into the computer as one of the following then repeat all the above steps:
  1. A Windows user with administrative rights
  2. The local administrator Windows account - Username = administrator 
  ODBC Client Setup Instructions.docx

Was this article helpful?