Yes, an update for Payroll 7 is required to ensure compliance with tax forms and magnetic media files.

Note: If you are currently using Payroll 6 with the Financial Edge, you must convert to Payroll 7 before processing tax forms since Payroll 6 is no longer compliant with tax requirements.

The end-of-year release incorporates final changes from the IRS and state tax authorities, including 2008 W-2 changes and the 2009 tax tables. The end-of-year patch for version 7.77 must be installed before processing your 2008 W-2s.

For more information about the end-of-year process, refer to The Financial Edge End-of-Year FAQs.