The SQL Server versions of our software install and use MDAC version 2.7.

Although we do not test with MDAC versions other than the version which is included in the software, some issues have been resolved by updating to MDAC version 2.8. We recommend installing newer MDAC versions in a test environment first to determine if any potential environmental issues occur. Refer to MSDN Library's MDAC 2.8 Overview for more information on MDAC 2.8.