This issue can occur for multiple reasons. Some causes of this issue were resolved in the Raiser's Edge version 7.96, which was released in November 2016 and applied to databases in Blackbaud Hosting Services.  If your database is installed locally, download and install the latest version and patch, if applicable.  

In 7.96 and above, this issue can occur if one of the records being merged is missing information in a required field, such as the Date from field on an Assigned Solicitor. To resolve this:
  • Check each field on the constituent record, relationship records, etc. for a required field that is blank. 
    • Enter valid information in this required field.
OR
  • Go to Config > Fields and unmark Required for the problem field. If the checkbox next to the field is grayed out, the field is Required by default and cannot be changed. 
If you are experiencing this issue and it is not caused by blank required fields, click Chat with Support, reference this article, and provide the following information so we can assist you:   
  • Examples of some of the affected Constituent IDs
  • Backup of the database
  • Version of Raiser's Edge and screen shot of Help > About the Raiser's Edge

OR
  1. Create a new blank constituent with just a Last Name (and any other required fields) 
  2. Merge one of your existing records into this new record (don't choose the option to delete the source constituent)
  3. Repeat steps 1 and 2 for the second of the constituent records that needs to be merged (this will result in a total of four records for this person)
  4. Once you have verified that these two merges processed successfully, delete the original two records
  5. Merge the two new records together.