The following Blackbaud products are compatible with Microsoft Office 2007:
  • The Raiser's Edge version 7.82.1514 and higher 
  • The Raiser's Edge version 7.92.5508 is only compatible with SP3
  • The Education Edge version 7.70.638 and higher
  • The Financial Edge version 7.70.638 and higher
  • The Researcher's Edge version 2.2.1.8
  • Blackbaud Student Information System                       
  • Blackbaud CRM

Note: If you use The Raiser's Edge and you integrate with Outlook, refer to BB402644 

As of August 23, 2007, other Blackbaud products are not supported with Office 2007.

Note: We recommend all users be on the same version of Microsoft Office because not all versions of Office are compatible with each other. Even though both versions of Office may be compatible with our program(s), if users at your organization are on different versions of Office, they may experience Office compatibility issues. For example, you have some users who use Word 2003 and some that use Word 2007. If a user on Word 2007 creates a merge document in Word 2007 format (.docx or .docm) to be used with one of our programs, users on Word 2003 may receive errors when trying to merge these letters. This is because the user's version of Word is not compatible with the letters created in a more recent version of Word. For compatibility issues between Office versions, refer to Microsoft's support site.