Error: The detected version of SQL Server cannot be used because it does not meet the minimum Service Pack requirement when installing

When running setup.exe to install the Blackbaud software user receives a 'The detected version of SQL Server cannot be used because it does not meet the minimum Service Pack requirement.  Would you like to install Blackbaud's SQL Server instance?  To install Blackbaud's instance and continue the installation, click Yes. You will need to attach your databases to Blackbaud's SQL Server instance after the installation completes.  To stop the current installation after the remaining prerequisites have completed installing, click No. After installing the required SQL Server Service Pack, you may re-run the Blackbaud setup process to complete the installation' error message.

If currently on SQL Server 2000 Service Pack 3a, download and install SQL Server 2000 Service Pack 4 from Microsoft's website.

 

If currently on SQL Server 2005 Service Pack 1, download and install SQL Server 2005 Service Pack 2 from Microsoft's website.

Note: SQL Server 2005 Service Pack 3 is not supported for The Education Edge and The Financial Edge versions 7.75 and lower, or The Raiser's Edge. If you are on Service Pack 3, then you will need to revert back to Service Pack 2. See Microsoft's "Uninstall Considerations"


If you receive the above error when installing version 7.77.245 of The Financial Edge or The Education Edge, then see Knowledgebase Solution BB576644

Environment

 Reported in version 7.70

Was this article helpful?