This issue was resolved by matching the plug-in version with Blackbaud NetCommunity
If there is not a plug-in mismatch, select "Yes" to delete the transaction when prompted to resolve the issue