Because we've made changes specific to Integration in both The Raiser's Edge and The Education Edge, you should:

  • Update to the following versions:
    • The Education Edge version 7.75 patch 10 or higher
    • The Raiser's Edge version 7.85 patch 1 or higher
    You can download the latest versions and patches from our website. Refer to the patch readmes on each downloads page for a list of all resolved issues.
  • Run synchronization every 15 minutes to prevent data integrity issues. We strongly recommend setting up synchronization to run as a scheduled Windows task every 15 minutes.
  • Maintain valid backups of your Education Edge and Raiser's Edge databases is the most important step you can take to protect your data because your data files are irreplaceable. Database backups can help us troubleshoot Integration issues such as changes to addresses and relationships before and after synchronization. Please ensure you are regularly creating and testing your database backups.