Starting with Blackbaud NetCommunity version 5.6, SQL server 2008 is compatible.
In the next release of Blackbaud NetCommunity scheduled for first quarter of 2010, Blackbaud NetCommunity will release a version that will require Microsoft SQL Server 2008, and Microsoft SQL Server 2005 will no longer be supported. Microsoft SQL 2008 will improve our product platform and provide additional capabilities.
Please review the latest system requirements for your product before updating.