The Raiser's Edge 7.91.5056, patch 20 and higher (including 7.92.5508) is compatible with the 32-bit version of Microsoft Office 2010.  This applies to both 32-bit and 64-bit operating systems, but is limited to Office 2010 32-bit only.  Microsoft Office 2010 64-bit is not compatible with The Raiser's Edge at this time.  There is currently not an estimated time frame for 64-bit compatibility.

Note: The Blackbaud Hosting Services Boston data center runs Microsoft Office 2007. As these environments are accessed via Citrix, the version of Office installed on the local workstations does not matter and has no effect on The Raiser's Edge.

We'll update the system requirements and this article if the compatibility changes.