The Raiser's Edge 7.80 is not compatible with Microsoft Office 2007 or Windows Vista.  Download and install the latest version of The Raiser's Edge to be compatible.

Additional information:

Refer to our system requirements for the latest compatibility information.