Refer to our system requirements for the latest compatibility information.  Windows 7 is supported in the Blackbaud Hosting Services environment.  Please confirm that you are running the latest Citrix Metaframe client.