Below are Payment Application Data Security Standards (PA-DSS) Terms and Conditions that appear when you click The Raiser's Edge 7.95 or higher download EXE for the first time.

Terms and Conditions

Before downloading The Raiser’s Edge 7.95, review the following information. To download the update, you must agree to the terms below. You may receive these terms and conditions again for The Raiser's Edge 7.95.

Warning: Raiser's Edge 7.95 contains major changes to the database structure for constituent records. Review the New Features Guide for more information.

If your organization integrates with Financial Edge, Education Edge, Blackbaud Student Information System, or Student Billing you must follow the update process in What do I need to do to prepare for the update to The Raiser's Edge 7.95?. Failure to follow this process may result in data loss.

Blackbaud is implementing plans to comply with the new Payment Card Industry Data Security Standard (PCI DSS). PCI DSS is a set of requirements developed by the major credit card companies to enhance credit card data security. All organizations that process, store, or transmit payment card data must be PCI DSS compliant or risk losing their ability to process credit card payments.

In The Raiser's Edge 7.95, you have the option to replace credit card information in the database with reference tokens and store credit card information in the Blackbaud Payment Service (BBPS). All credit card data and merchant account information is kept in this secure, PCI DSS-compliant environment and only the last four credit card digits will display on constituent and gift records. This version meets the Payment Application Data Security Standards (PA DSS), a requirement for compliance with PCI DSS.

If you are upgrading from 7.91 or below:

To log into The Raiser's Edge 7.95 for the first time, users must enter their passwords in all capital letters (e.g., "PASSWORD1" instead of "password1"). Before you install The Raiser's Edge 7.95, we recommend you back up the database.

If you choose to use BBPS:

  1. After you have read these instructions, click I accept at the bottom of this page.
  2. On the next page, follow the instructions to create a BBPS account.

    Note: There is no additional cost or maintenance for using BBPS. For organizations using non-preferred providers with Blackbaud NetCommunity and NetSolutions, we will continue to charge an annual fee. If you have any questions concerning provider fees, contact your account manager at 800.443.9441 or email solutions@blackbaud.com.
     
  3. Download The Raiser's Edge 7.95.
  4. After you install the update, the first user who logs in will be prompted to use BBPS to store credit card data. This prompt will appear only once for the first user who logs into the database.

If you choose not to use BBPS:

  1. After you have read these instructions, click I accept at the bottom of this page.
  2. Download The Raiser's Edge 7.95.
  3. After you install the update, the first user who logs in will be prompted to delete all credit card information from the database and decline BBPS. This prompt will appear only once for the first user who logs into the database. Your organization will no longer be able to process, store, or transmit credit cards in The Raiser’s Edge.

Note: If you later wish to use BBPS after declining it that is an option


For additional information regarding this update, PCI DSS compliance, and BBPS, review Important Changes in The Raiser’s Edge 7.93 and the Blackbaud Payment Service Agreement.