While it is recommended that all users be on the same version, as long as the version of Office they are running is compatible with the version of Raisers Edge, and the versions of Microsoft Office are compatible with each other, then there should not be any functionality issues.

Please refer to the following solutions for more information on what versions of Raisers Edge are compatible with this version of Microsoft Office. Office 2007