Please check the System Requirements for your product(s) to find the latest information on the operating systems that are supported. 

Supported on Windows 7:
  • The Financial Edge/ Education Edge / Student Information Systems version 7.82.104.0 and higher.
  • The Raiser's Edge version 7.91.5056.0 and higher (SQL Server).
  • The Patron Edge version 3.401 patch 3 and higher.
Supported on Windows 7 SP1 - 32-bit and 64-bit (released by Microsoft on 2/22/2011):
  • The Financial Edge/ Education Edge / Student Information Systems version 7.82.104.0 and higher.
  • The Raiser's Edge version 7.91.5056.14 and higher (SQL Server).

For Windows 7 compatibility with Blackbaud Application Hosting, see Knowledgebase Solution BB706009.