Note : Before you proceed with the following instructions, back up the database. If your organization integrates multiple Blackbaud products, refer to the Additional Requirements section of the backup article.
 
Import allows you to import new records and update existing ones. The following instructions walk you through the basic importing steps and explain the options available in the import parameters.
  1. Create a data file. A data file normally consists of two components:
    • Headers are the pointers to each specific Raisers Edge field.
    • Data is the information being added such as names, addresses, and constituencies.

      Note: Although headers are not required in The Raiser's Edge 7, we recommend using them. Otherwise, you must manually map the fields in the data file to the corresponding field in The Raiser's Edge. In the example below, the headers are in row 1 and the data is in rows 2 and 3
      .
  2. In Administration, click Import
     
  3. Highlight the appropriate import type, such as Constituent, Constituent Address. In the example below, we use Constituent, Constituent.
     
  4. Click New Import.
     
  5. In the What do you want to do? frame, define what to accomplish with the import:
    • Import new records imports new records such as constituents and gifts into The Raiser's Edge 7. The record in the data file must contain a unique identifier (import ID, constituent ID, or social security number) that does not already exist in the database.
    •  Update existing records updates existing records with new information such as address changes. The record in the data file must contain a unique identifier (import ID, constituent ID, or social security number) that already exists in the database to link the record in the data file to the record in The Raiser's Edge.
    • Create import file creates a file to share with outside vendors, such as a mailing house or others within your organization. The records in the file can be updated and imported back into The Raiser's Edge. For more information on creating an import file, refer to How to create an import file.

      Note: To import new records, update existing records, or validate the data, you must create the import file first. The file must be formatted in accordance with the parameter settings selected in the import such as *.txt, *.csv, or *.prn files.
  6. Complete the checkboxes enabled in the Options frame. These checkboxes are enabled and disabled based on your selection in the What do you want to do? frame. The checkboxes for importing or updating are:
    • Validate data only validates the data contained in the import file without actually importing the data into The Raiser's Edge. This option searches the import file for errors you may encounter during an import.
    • Create new table entries creates new table entries for those found in the import file that do not already exist in The Raiser's Edge.
    • Import records not found as new records identifies as "new" any update record not matched to an existing record in your database. The program then creates a new record for the data.
    • Automatically reciprocate relationships appears for constituent, individual relationship, and organization relationship imports only. If marked, the program automatically adds the relationship and the reciprocal relationship on the relationship's record if the relationship is a constituent. However, the program fills in the Relationship and Reciprocal fields only if the Relationship field is populated on the constituent record.
    • Use duplicate criteria for new records uses the duplicate criteria established from Business Rules in Configuration when checking for duplicate records during the import process.
       
  7. In the What file do you wish to import? frame, enter the Import file name. This is the name of the file that contains the updated information to import. To access a list of existing import files, click the ellipsis and browse for the data file.
     
  8. Complete the How do you want the system to identify existing constituents? frame. All the IDs must be unique. You can select one of the following:
    • Use the Import ID - The program defaults to this option. This is a program-generated number the program assigns your records. If you select this option, the program uses the import ID to identify existing records.
    • Use the Constituent ID - If you select this option, the program uses the constituent ID number to identify existing records. The program generates this number based on your selection in Business Rules in Configuration.
    • Use the Social Security Number - If you select this option, the program uses the constituent Social Security Number to identify existing records. You enter this number on the constituent records.

      Note: If using constituent Social Security Numbers as an identifier when importing records, you must include the dashes when entering the number in the import file.
       
  9. In the What is the format of this import file? frame, select one of the following options:
    • Delimited - Characters separate the fields. You must select a character, such as a comma, to separate the fields. For example, if you select comma delimited, fields are separated as follows: "Phone", "Address", "Name", etc. Carriage returns and line feed breaks separate records.
    • Fixed width - Fields and records have a set length. This option allows you to define the length of the records (fields) to import. Enter the number in the Rec. length field. For example, if you set the record length at 20, all records with 20 characters or less import into the program complete. Any record over 20 characters is truncated at the 21st character. Also, the next record to import starts immediately after the 20th character, so if you have a 20-character record, there is no space between it and the next record. In the No. of fields field, enter the number of different fields there are in a record.
       
  10. Click Next to move to the File Layout tab.
     
  11. From the File Layout tab, complete the Field Separators and Text Qualifiers frame. Although the program defaults to the Comma option, you may select to separate fields using a Tab, Semicolon, Space, or Other. The Other option allows you to define the field separator, using a separator other than the ones listed.
     
  12. Complete the Text qualifier field. This defines the beginning and end points of your field. For example, if you want to include the Address block field in your import file using quotation marks as your text qualifier and commas as your separator it would appear as follows: "AddrBlock",

    The text qualifier also allows the program to distinguish between actual punctuation in a string of text and the field separator. For example, if you select the comma as your separator and then try to import the following address - 100 Main Street, Apt. 23F - the program may think the comma indicates a new field. By placing a text qualifier at the beginning and end of your field - "100 Main Street, Apt. 23F" - the program knows all text contained between the text qualifier is part of the same field.
     
  13. Complete the Import Field Names frame. Select one of the following options:
    • Field names are on the first line of the import file - If you select this option, the first line in the import file is the header line or row, which contains the Import Name of the fields included in the file. The remaining lines contain data records, one line per record. So, in a Constituent import, each constituent record is given its own line; in a Gift import each gift is given its own line; in a Constituent Phone import each phone number is give its own line.
    • Import file does not contain field names - This option does not require you to create a header. The program assumes the first line of the import contain data records.
    • Field names are in a separate file - This option imports record information from fields defined in a file other than the import file. The header and import records are formatted using the field code names, separators, and text qualifiers explained in steps 8 and 9, but the header record and the import file are contained in separate files.

      Note: Field names are case sensitive
       
  14. Click Next to move to the Fields tab.
     
  15. On this tab, map the fields in the import file to the appropriate location in The Raiser's Edge. The program attempts to automatically match all your Field to Import entries with fields in The Raiser's Edge if you used headers in the data file. This is not a case-sensitive process.

    Note: If the program does not recognize the headers or if you did not use headers, you must manually map to the field. All Available Fields appear in the box to the left of the grid.
     
  16. To manually map field names, in the Available Fields frame, use the Show field to filter the field categories appearing in the treeview. You can select All to display every field category, or you can select a specific field category.

    Note: The import values contained in your import file must be arranged in the same order you arrange the field names on the Fields tab. 
     
  17. Click Next to move to the Summary tab. The Summary tab allows you to review the import parameters and other information selected in the import. It also offers miscellaneous import checkboxes.
     
  18. Complete the Import Options frame. You can select from the following checkboxes (we recommend selecting all available options):
    • Create exception file of records not updated/imported - Mark this checkbox to generate an exception file at the end of your import. The file contains all fields the program did not successfully update or import. Enter a name for your exception file and the path where you want it created.
    • Create an output query of the records imported/updated - Mark this checkbox to create a query of all records imported or updated. The query type depends on the type of import file selected. For example, if you run a constituent import, a constituent output query is created.
    • Create control report - Mark this checkbox to print a report listing the criteria fields and criteria operators selected for the import. The report also shows the import name and the directory path where you saved the import. Select Preview to view the report on your screen before printing or Print to print the report.
       
  19. Click Import Now to begin the import or update.