If you encounter this issue in the latest version and patch of Raiser's Edge please contact support and reference this article.
If you are on version 7.93 or higher of The Raiser's Edge, please download and install the Delete Table Entry Plugin.How to download and run the Delete Table Entry plug-in for The Raiser's Edge