Internet Explorer 8 is not compatible with The Raiser's Edge version 7.85 or lower.

Internet Explorer 8 is compatible with The Raiser's Edge version 7.91 or higher.

Refer to the system requirements (PDF) for more compatibility information.

Revert back to Internet Explorer version 7 or lower if on version 7.85 or lower of The Raiser's Edge.
add 'about:internet' to trusted sites by un-checking 'require server verification (https:)