The Blackbaud Payment Service (BBPS) is a service that Blackbaud offers to work alongside our products to help ensure our software is PCI Compliant for your organization. Registering for this service is the first step in updating to a PCI Compliant version of the Blackbaud product(s) you use.  Even if your organization initially declined BBPS, you can still register and create an account.

If your organization has not updated to the PA-DSS compliant version of The Raiser's Edge (7.91 or higher) download the update and signup for a BBPS account.  Make note of your BBPS credentials so that you can enter them when prompted during the update.

If your organization initially declined to use the BBPS but now desire to use it, go to https://bbps.blackbaud.com/ to create an account.

  • If you have already updated, you must log into The Raiser's Edge as Supervisor and enter your BBPS credentials in Config > General.
  • If you have not updated, make note of the BBPS credentials you create so that you can enter them when prompted during the update.

For more information, review the Blackbaud Payment Services Agreement.