The Raiser's Edge 7.91.5056, patch 20 and higher is only compatible with the 32-bit version of Microsoft Office 2010.   Attach the document using a workstation with Office 2003 or 2007 installed or update The Raiser's Edge to the latest version and patch.

For more information refer to Is Office 2010 compatible with The Raisers Edge?