This error is thrown due to BBEC v2.9 not being compatible with MS Office 2010. 
The Blackbaud Excel Add-in Deployment Utility/Blackbaud Communications Word Add-in Deployment Utility does not install the needed Microsoft Office Primary Interop Assemblies for Office 2010. 

The prequisites for this Add-In can be downloaded here: 

 Microsoft Office 2010 Primary Interop Assemblies

Visual Studio Tools for the Office System 3.0 Runtime Service


Note: We provide links to third-party websites in an effort to help you resolve your issue. We are not responsible for the information on third-party websites, and we cannot assist with implementing resolutions from these websites.