Although IATS is one of the supported credit card processors, it is not required.  Please see the 3rd party software requirements section of the Blackbaud NetCommunity system requirements for a list of credit card processors from which to choose.