This error is often caused when the SQL Server instance that you are using to attach/restore with is lower than the version of SQL Server that the database files are on or that the backup was created with.

To resolve this error, attach/restore your database or backup using the same version or higher version of SQL Server that the database files are on or that the backup was created with.