FundWare 7.70 was available on the Support website on 8/13.  If you are unable to see the download, it may be due to products our records show you have installed.
You will not be able to see the release if you have Corridor or PaperSave with FundWare.

 
 Supported Environments Unsupported Environments
Server OS
  • Windows Server 2008 (32-bit and 64-bit); SP1 is supported.
  • Windows Server 2008 R2 (32-bit and 64-bit); SP1 is supported.
 
Windows Server 2003
 
Workstation OS
  • Windows XP Professional (32-bit and 64-bit); SP3 is required. 
  • Windows Vista (32-bit and 64-bit); SP1 and 2 are supported.
  • Windows 7 (32-bit and 64-bit); SP1 is supported.
 
Any Home versions of workstation OS
SQL
  • SQL Server 2008 Express (32-bit and 64-bit) SP1 is required
  • SQL Server 2008 Standard(32-bit and 64-bit) SP1 is required
  • SQL Server 2008 R2 Express (32-bit and 64-bit)
  • SQL Server 2008 R2 Standard (32-bit and 64-bit)
SQL Express versions are for use on FW Pro Systems. The full sql versions are for Enterprise. They are not interchangeable.
 
  • SQL Server 2005
  • SQL Server 2000

Many of the challenges involve third party products rather than FundWare itself, so significant testing time has been needed to determine which products are compatible.

PaperSave will not be available with 7.70, as the released papersave version is not compatible with 64 bit operating systems.
Corridor also is not compatible with 64 bit operating systems.
Sql server 2012  will not be supported on the initial release.
Office 2010 32 bit will work with the release including working with F9.  Office 2010 64 bit is not supported.
The FundWare 20 Pines suite of products IS compatible. (APC, etc)
FundWare core modules, including Classic AR will all work.

There are minor CRs that are being addressed but the focus of the release is on the 64 bit operating system.
If a client is already on 7.60, you do not need a new registration key.  It is only needed if you are currently at 7.50 or below.