When this error occurs, it indicates the Core Components of the NetCommunity installer is trying to link to a Database. 

If your organization hosts the Core Components of NetCommunity and you are trying to install or update the Core Components
Installer prompts for Database Connection information [Database server, Database name, etc] when running the base version installer on any server. If the incorrect database is entered the resulting error will occur. If this path does not exist, then you are likely running the installer on the wrong server. Please verify you are running the installer on the NetCommunity server and against NetCommunity database. Confirm the database you specified in the installer is the NetCommunity database. Do not enter the Raiser's Edge database, for example. 

If your organization hosts the Raiser's Edge and you're trying to update The Raiser's Edge Web Service
This error may occur if you selected to install the Core Components of NetCommunity on The Raiser's Edge Web Server (REWS). On the REWS, you should only being installing The Raiser's Edge Web Service and the Raiser's Edge Plugin from the installer's options. 
See how to install or update the REWS for more information.