Please follow the below listed steps until your issue has been resolved:

Note: Get the approval and assistance of your IT staff before performing this task
  1. In Internet Explorer, go to Tools>Internet Options>Connections>LAN Settings and uncheck the Proxy Server setting.
  2. Uninstall Browser Safeguard in Programs and Features as this program can cause conflicts. If the issue persists, please continue.
  3. Uninstall the Citrix plug-in currently installed on your affected workstation and install the latest version of the Citrix Client.
    • Note: If this does not resolve the issue, uninstall the plug-in again and continue the below instructions.
  1. Open the Registry of your Windows machine (for XP machines; for Vista & Windows 7).
  2. Navigate in the registry to the following directory: HKey_Current_User/software/citrix.
  3. Select the citrix folder.
  4. Backup the registry.
  5. After the registry has been backed up, delete the citrix folder.
  6. Uninstall your current Citrix Metaframe client and then reboot the machine.
  7. Follow the steps for ensuring citrix can communicate with your browser. Attempt to log into your hosted product again.
  8. Install the newest version of the Citrix plug-in on the machine, overwriting the current installation and attempt to launch your product again.
  9. Re-created the affected windows profile and attempt to install the citrix plug-in again.
  10. Re-image the affected workstation and attempt to install the citrix plug-in again.


If the issue is still persisting after completing the above steps, please prepare the below listed information and Click Chat with Support and reference this article. 
  • Detailed steps to duplicate the issue (click by click).
  • The exact wording or a screenshot of the error experienced.