The following are requirements to install Blackbaud Online Express: 
  1. The Raiser's Edge version 7.92.5508 or higher.
  2. Internet Explorer 9 or higher.
  3. Must have a local administrative Windows account on the computer that runs the installer.
  4. Supervisor rights within The Raiser's Edge to install/provision the first time.
Additional Information: