Also review the compatibility information and system requirements before you update:
  • If you integrate with Online Campus Community and/or Online Admissions, you must be on Blackbaud NetCommunity version 6.10 patch 8 or higher and Online Campus Community 3.12 or higher.
  • If you use Online Admissions version 1, do not install Blackbaud Student Information System version 7.86; Online Admissions version 2 is compatible.
  • SQL Server Requirement Changes:
    • If you use SQL Server 2005, service pack 4 is required.
    • If you use SQL Server 2008, service pack 1 is required.
  • If your database includes financial software and you have installed The Financial Edge update, you do not need to install the The Education Edge update.
  • Update Guide (PDF)