As per the Blackbaud Hosting Services System Requirements
  • Microsoft .NET Framework 2.0 SP1 or newer should be installed.