Error: Spouse lookup ID required - exception in Constituent Update Batch import when Spouse lookup ID is marked as Required but included in the import file

When importing records into a Constituent Update Batch, users have the option to mark certain fields as required in the template, indicating that they need to be included when importing. However, if the Spouse lookup ID is marked as required, users receive the import exception below, even if the Spouse lookup ID is populated in the file:

Spouse lookup ID is required.

When Spouse lookup ID is not marketing as required, but that field is included in the import, the import completes with no exceptions.

Download and install the latest patch, which contains all fixes from previous patches. If you are running an older version, download and install the latest version and then the patch. 

Environment

 3.0.516 ; 2.91.1535
 3.0.516, Service Pack 7

Was this article helpful?