The Raiser's Edge, The Financial Edge, The Education Edge and Blackbaud Student Information System are not compatible with Chrome operating systems (OS).   Please refer to our system requirements for a full list of Windows operating systems that are compatible with your Blackbaud product.

For additional information on supported methods to remotely connect to a Raiser's Edge, Financial Edge, Education Edge or Blackbaud Student Information System database from an unsupported operating system, please refer to:  Knowledgebase Solution: BB50293.