The only version of Apache that is supported is the version that comes with the download file for RE Connector.