Per the release notes here, the following browsers are supported by Blackbaud:

Luminate Online Administrator interface:

  • Google Chrome, current stable version and one version back
  • Microsoft Internet Explorer, versions 10 - 11
  • Mozilla Firefox, current stable version and one version back


Luminate Online Constituent interface:

  • Apple Safari, current stable version and one version back
  • Google Chrome, current stable version and one version back
  • Microsoft Internet Explorer, versions 10 - 11
  • Mozilla Firefox, current stable version and one version back

Luminate CMS Administrator interface:
  • Microsoft Internet Explorer, versions 10 - 11
  • Mozilla Firefox, current stable version and one version back


Luminate CMS Constituent interface:

  • Google Chrome, current stable version and one version back
  • Microsoft Internet Explorer, versions 10 -11
  • Mozilla Firefox, current stable version and one version back