This error is usually caused from running an older Connector version such as 4.1.2.8 on a Raiser's Edge version 7.91 or higher.  If you are still receiving the same error after upgrading your Connector version, please Chat with Support and reference this article.