Also review the compatibility information and System Requirements before you update.

If you integrate with Online Campus Community, Online Reenrollment and/or Online Admissions, you must be on version 6.51 or higher

SQL Server Requirements Changes:
  • If you use SQL Server 2005, Service Pack 4 is required.
  • If you use SQL Server 2008 R2, Service Pack 1 is required and Service Pack 2 is supported.
  • If your database includes financial software and you have installed The Financial Edge update, you do not need to install Blackbaud Student Information System update.
Windows XP is no longer supported by Microsoft and Blackbaud recommends upgrading to a newer, supported operating system.