Error: A feature you have selected requires the ASP .NET role service - when installing NetCommunity

When attempting to install Blackbaud NetCommunity onto the Raiser's Edge Web Services server and the server is a  Microsoft Windows Server 2012 R2 Standard Server, the following error may occur: A feature you have selected requires ASP.NET role service and the server does have .Net 4.5 already installed.
 
  1. Log into The Raiser's Edge Web Services server
  2. Open Server Manager
  3. Click Add roles and features
  4. Click Next until you get to Server Roles section
  5. Mark checkboxes for the following in the Application Development section: (Web Server IIS > Web server > Application Development)
    • .NET Extensibility 3.5
    • .NET Extensibility 4.5
    • Application Initialization
    • ASP
    • ASP.NET 3.5
    • ASP.NET 4.5
    • CGI
    • ISAPI Extensions
    • ISAPI FILTERS
    • Server Side Includes
  6. Mark checkboxes for the following in the Management Tools section:
    • IIS Management Console
    • IIS 6 Management Compatability
    • IIS Management Scripts and Tools
  7. Click Next until you can click Install
  8. Click Install
  9. Rerun Installer for NetCommunity

Environment

 6.58.806

Was this article helpful?