How to enable Microsoft .NET Framework 3.5 on your operating system

In order to use The Raiser's Edge, The Education Edge or The Financial Edge, Microsoft .NET Framework 3.5 Feature (which includes .NET Framework 2.0 and .NET Framework 3.0) needs to be enabled.
Prior to installing your Blackbaud product, refer to our System Requirements to verify that the version of your Blackbaud product is supported on your operating system.

To enable Microsoft .NET Framework 3.5 (which includes .NET Framework 2.0 and .NET Framework 3.0), complete the instructions listed below for your particular operating system: 
Please contact the appropriate software vendor or IT professional for assistance with this process or issue, which is beyond Blackbaud's scope of support.
NOTE: We provide links to third-party websites in an effort to help you resolve your issue. We are not responsible for the information on third-party websites, and we cannot assist with implementing resolutions from these websites.

If Microsoft .NET Framework 3.5 is not enabled, then common errors you may receive are:

Environment

 Windows 7 (32-bit);Windows 7 (64-bit);Windows 8 (64-bit);Windows 8.1 (64-bit);Windows 10 (64-bit);Windows Server 2008 (64-bit);Windows Server 2008 R2;Windows Server 2012;Windows Server 2012 R2

Was this article helpful?