You can find a list of supported browsers here:
https://www.blackbaud.com/files/support/helpfiles/luminate-releasenotes/Luminate_Release_Notes.htm#Supported%20Browsers.htm

Regarding IE specifically, only versions 10 and 11 will be supported. IE 9 and prior do not work well with some of the features we plan to roll out going forward.  

Here is a full list of Luminate supported browsers starting in 15.3:

Luminate Online Administrator interface

  • Freedom Scientific JAWS 10
  • Google Chrome, current stable version and one version back
  • Microsoft Internet Explorer, current stable version and one version back
  • Mozilla Firefox, current stable version and one version back

Luminate Online Constituent interface

  • Apple Safari, current stable version and one version back
  • Freedom Scientific JAWS 10
  • Google Chrome, current stable version and one version back
  • Microsoft Internet Explorer, all stable versions 9 and later
  • Mozilla Firefox, current stable version and one version back