The Information Edge is only compatible with:
SQL Server 2000 Standard SP4
SQL Server 2000 Enterprise SP4

The Information Edge is not compatible with:
MSDE
SQL Server Express
SQL Server 2005
SQL Server 2008
SQL Server 2008 R2