Error: The database you are logging into has been upgraded to a higher version than what has been installed on this machine. Please upgrade your system before logging in.

When logging into The Financial Edge database after installing/upgrading, users receive the following error, even though a patch has not been applied to any machine on which The Financial Edge has been installed and updated:
 
Error: The database you are logging into has been upgraded to a higher version than what has been installed on this machine. Please upgrade your system before logging in. 

This issue occurs when the registry entry, which should get updated to reflect the updated patch level of the software when the update takes place, does not get updated correctly on at least one workstation. Once users log into The Financial Edge on this specific machine, they find that they now receive the above error when attempting to log in on every other workstation. Users are, however, able to successfully log into the database on the affected machine.
 
This issue has been resolved in The Financial Edge, Education Edge and Blackbaud Student Information System version 7.87 Patch 15.  To verify your version and patch, please review How to find the software version and/or patch number of my Blackbaud software.

If you are already using version 7.87 of The Finanical Edge, Education Edge, Blackbaud Student Information System, then download and install Patch 15 or higher for version 7.87 on your server, log into your database on the Blackbaud Management Console server and then deploy the patch to your workstations to resolve this issue.  If you are running an older version, then download and install the latest version and latest patch.
 

Environment

 Financial Edge
 7.84
 7.87
 15
 7.84.52 7.85.52 7.86.93 7.87.164

Was this article helpful?